Quantcast

genisoimage: Uh oh, I cant find the boot image 'isolinux.bin' !

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

genisoimage: Uh oh, I cant find the boot image 'isolinux.bin' !

robot_sql
HI:
Having a problem with Mondo 3.2.1-1 and RHEL6.

server:redhat6.5
mindi:mindi-3.0.2-1.rhel6.x86_64.rpm
mondo:mondo-3.2.1-1.rhel6.x86_64.rpm
#cat /var/log/mondoarchive.log
.......
Using XATTR068.GZ;1 for  ./archives/xattr_list.9.gz (xattr_list.14.gz)
genisoimage: Uh oh, I cant find the boot image 'isolinux.bin' !
DBG4: [Main] libmondo-fork.c->run_prog_in_bkgd_then_exit#614: child res = 255
DBG3: [Main] libmondo-fork.c->run_external_binary_with_percentage_indicator_NEW#685: Parent res = 255
INFO: Call to mkisofs to make ISO (ISO #1) ...failed
DBG1: [Main] libmondo-archive.c->make_iso_fs#1883: WARNING - make_iso_fs returned an error
.....

I confirm that syslinux is installed by syslinux-4.02-4.el6.x86_64.rpm.
[root@COM mondo.scratch.XSemWL]# find  / | grep isolinux.bin
/boot/syslinux/isolinux.bin
/usr/share/syslinux/isolinux.bin

[root@COM mondo.scratch.XSemWL]# rpm -qa | grep syslinux
syslinux-4.02-4.el6.x86_64

I use the following command can also be made mirror success. Why mondoarchive is failed?
[root@COM mondo.scratch.XSemWL]# mkisofs -o myiso11.iso -b isolinux/isolinux.bin -c isolinux/boot.cat -no-emul-boot -boot-load-size 4 -boot-info-table ./archives/


THANKS!!!
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Mondo-devel] genisoimage: Uh oh, I cant find the boot image 'isolinux.bin' !

Bruno Cornec-4
Hello,

robot_sql said on Thu, Oct 27, 2016 at 01:29:51AM -0700:
>#cat /var/log/mondoarchive.log
>.......

Please do not truncate the log file. The reason why this is not working is probably in the part you cut :-(

>genisoimage: Uh oh, I cant find the boot image 'isolinux.bin' !

Especially the log gives the full command line ised for genisoimage.

Bruno.
--
Open Source Profession, WW Linux Community Lead     http://www.hpintelco.net
HPE EMEA EG FLOSS Technology Strategist http://www.hpe.com/engage/opensource
FLOSS projects:    http://mondorescue.org         http://project-builder.org
Musique ancienne?   http://www.musique-ancienne.org  http://www.medieval.org

------------------------------------------------------------------------------
The Command Line: Reinvented for Modern Developers
Did the resurgence of CLI tooling catch you by surprise?
Reconnect with the command line and become more productive.
Learn the new .NET and ASP.NET CLI. Get your free copy!
http://sdm.link/telerik
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Mondo-devel] genisoimage: Uh oh, I cant find the boot image 'isolinux.bin' !

mrjoeyman
My message was deleted for not being a member, but I am a member. Also I didn't truncate the log info. I pasted it all in the body of the email message, and also included a word doc file with the same. Do I need to do it all over again?

Joel

On Fri, Oct 28, 2016 at 6:48 PM, Bruno Cornec <[hidden email]> wrote:
Hello,

robot_sql said on Thu, Oct 27, 2016 at 01:29:51AM -0700:
>#cat /var/log/mondoarchive.log
>.......

Please do not truncate the log file. The reason why this is not working is probably in the part you cut :-(

>genisoimage: Uh oh, I cant find the boot image 'isolinux.bin' !

Especially the log gives the full command line ised for genisoimage.

Bruno.
--
Open Source Profession, WW Linux Community Lead     http://www.hpintelco.net
HPE EMEA EG FLOSS Technology Strategist http://www.hpe.com/engage/opensource
FLOSS projects:    http://mondorescue.org         http://project-builder.org
Musique ancienne?   http://www.musique-ancienne.org  http://www.medieval.org

------------------------------------------------------------------------------
The Command Line: Reinvented for Modern Developers
Did the resurgence of CLI tooling catch you by surprise?
Reconnect with the command line and become more productive.
Learn the new .NET and ASP.NET CLI. Get your free copy!
http://sdm.link/telerik
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel



--
"Before you criticize someone, walk a mile in their shoes. That way, you are a mile away, and you will have their shoes."

------------------------------------------------------------------------------
The Command Line: Reinvented for Modern Developers
Did the resurgence of CLI tooling catch you by surprise?
Reconnect with the command line and become more productive.
Learn the new .NET and ASP.NET CLI. Get your free copy!
http://sdm.link/telerik
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Mondo-devel] genisoimage: Uh oh, I cant find the boot image 'isolinux.bin' !

Bruno Cornec-4
Joel West said on Sat, Oct 29, 2016 at 08:40:01AM -0400:

>My message was deleted for not being a member, but I am a member. Also I
>didn't truncate the log info. I pasted it all in the body of the email
>message, and also included a word doc file with the same. Do I need to do
>it all over again?

Well, if you send a msg with a different mail address, you're considered
as not being a subscriber. Also, there is a limit to 400 kB for attachments
so compress them before sending. No word file please. I'm a Linux user, so
a gzip compressed log made on the original system is all what I want.

The log wasn't attached anyway, and in the bidy of the mail you truncated
the content, which isn't helpful for me.

Bruno.
--
Open Source Profession, WW Linux Community Lead     http://www.hpintelco.net
HPE EMEA EG FLOSS Technology Strategist http://www.hpe.com/engage/opensource
FLOSS projects:    http://mondorescue.org         http://project-builder.org
Musique ancienne?   http://www.musique-ancienne.org  http://www.medieval.org

------------------------------------------------------------------------------
The Command Line: Reinvented for Modern Developers
Did the resurgence of CLI tooling catch you by surprise?
Reconnect with the command line and become more productive.
Learn the new .NET and ASP.NET CLI. Get your free copy!
http://sdm.link/telerik
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Mondo-devel] genisoimage: Uh oh, I cant find the boot image 'isolinux.bin' !

mrjoeyman
Thanks for the reply! So if I meet all the requirements from this email address (I dont know what other one to use) will you take a look at my log? I will save it as you said. Again Bruno, thanks.

Joel

On Sun, Oct 30, 2016 at 6:38 PM, Bruno Cornec <[hidden email]> wrote:
Joel West said on Sat, Oct 29, 2016 at 08:40:01AM -0400:

>My message was deleted for not being a member, but I am a member. Also I
>didn't truncate the log info. I pasted it all in the body of the email
>message, and also included a word doc file with the same. Do I need to do
>it all over again?

Well, if you send a msg with a different mail address, you're considered
as not being a subscriber. Also, there is a limit to 400 kB for attachments
so compress them before sending. No word file please. I'm a Linux user, so
a gzip compressed log made on the original system is all what I want.

The log wasn't attached anyway, and in the bidy of the mail you truncated
the content, which isn't helpful for me.

Bruno.
--
Open Source Profession, WW Linux Community Lead     http://www.hpintelco.net
HPE EMEA EG FLOSS Technology Strategist http://www.hpe.com/engage/opensource
FLOSS projects:    http://mondorescue.org         http://project-builder.org
Musique ancienne?   http://www.musique-ancienne.org  http://www.medieval.org

------------------------------------------------------------------------------
The Command Line: Reinvented for Modern Developers
Did the resurgence of CLI tooling catch you by surprise?
Reconnect with the command line and become more productive.
Learn the new .NET and ASP.NET CLI. Get your free copy!
http://sdm.link/telerik
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel



--
"Before you criticize someone, walk a mile in their shoes. That way, you are a mile away, and you will have their shoes."

------------------------------------------------------------------------------
The Command Line: Reinvented for Modern Developers
Did the resurgence of CLI tooling catch you by surprise?
Reconnect with the command line and become more productive.
Learn the new .NET and ASP.NET CLI. Get your free copy!
http://sdm.link/telerik
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Mondo-devel] genisoimage: Uh oh, I cant find the boot image 'isolinux.bin' !

mrjoeyman
Here are the files zipped like you asked. If I need to send them from some other email address, like one from the Mondo site or something please let me know. Thanks!

Joel West

On Sun, Oct 30, 2016 at 10:33 PM, Joel West <[hidden email]> wrote:
Thanks for the reply! So if I meet all the requirements from this email address (I dont know what other one to use) will you take a look at my log? I will save it as you said. Again Bruno, thanks.

Joel

On Sun, Oct 30, 2016 at 6:38 PM, Bruno Cornec <[hidden email]> wrote:
Joel West said on Sat, Oct 29, 2016 at 08:40:01AM -0400:

>My message was deleted for not being a member, but I am a member. Also I
>didn't truncate the log info. I pasted it all in the body of the email
>message, and also included a word doc file with the same. Do I need to do
>it all over again?

Well, if you send a msg with a different mail address, you're considered
as not being a subscriber. Also, there is a limit to 400 kB for attachments
so compress them before sending. No word file please. I'm a Linux user, so
a gzip compressed log made on the original system is all what I want.

The log wasn't attached anyway, and in the bidy of the mail you truncated
the content, which isn't helpful for me.

Bruno.
--
Open Source Profession, WW Linux Community Lead     http://www.hpintelco.net
HPE EMEA EG FLOSS Technology Strategist http://www.hpe.com/engage/opensource
FLOSS projects:    http://mondorescue.org         http://project-builder.org
Musique ancienne?   http://www.musique-ancienne.org  http://www.medieval.org

------------------------------------------------------------------------------
The Command Line: Reinvented for Modern Developers
Did the resurgence of CLI tooling catch you by surprise?
Reconnect with the command line and become more productive.
Learn the new .NET and ASP.NET CLI. Get your free copy!
http://sdm.link/telerik
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel



--
"Before you criticize someone, walk a mile in their shoes. That way, you are a mile away, and you will have their shoes."



--
"Before you criticize someone, walk a mile in their shoes. That way, you are a mile away, and you will have their shoes."

------------------------------------------------------------------------------
The Command Line: Reinvented for Modern Developers
Did the resurgence of CLI tooling catch you by surprise?
Reconnect with the command line and become more productive.
Learn the new .NET and ASP.NET CLI. Get your free copy!
http://sdm.link/telerik
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel

logsformondosupport.tar.gz (76K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Mondo-devel] genisoimage: Uh oh, I cant find the boot image 'isolinux.bin' !

robot_sql
In reply to this post by Bruno Cornec-4
Thanks for the reply!
genisoimage command :
genisoimage -r -p MondoRescue -publisher www.mondorescue.org -A Mondo_Rescue_GPL_Version -J -boot-info-table -no-emul-boot -b isolinux.bin -c boot.cat -boot-load-size 4  -eltorito-alt-boot -e images/mindi-bootroot.img -no-emul-boot -o '/var/cache/mondo/redhatdb2-1.iso' -V 1 . >> /var/log/mondoarchive.log'

wrong reason:
When the mondorescue tools to implement the mirror command, the genisoimage  tool is the '/home/mondo.scratch.73etl3'  directory archive image, but the isolinux.bin in the '/home/mondo.scratch.73etl3/syslinux'  directory, so you need to copy the syslinux file inside the home directory can execute the command.(The above table of contents according to the actual situation contrast)
E.g:
[root@COM syslinux]# cp -r *.txt /home/mondo.scratch.73etl3
[root@COM syslinux]# cp -r *linux* /home/mondo.scratch.73etl3
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Mondo-devel] genisoimage: Uh oh, I cant find the boot image 'isolinux.bin' !

mrjoeyman
I understand now how to post from within the mailing list   Sorry for not doing so up to now. Thanks for being understanding!
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Mondo-devel] genisoimage: Uh oh, I cant find the boot image 'isolinux.bin' !

Bruno Cornec-4
In reply to this post by mrjoeyman
Hello,

Joel West said on Sun, Oct 30, 2016 at 11:24:15PM -0400:

>Here are the files zipped like you asked. If I need to send them from some
>other email address, like one from the Mondo site or something please let
>me know. Thanks!

The e-mail address is now fine ! Thanks for the logs.

You seem to have 2 issues:
1/ minor: your main kernel is detected as a Xen kernel but not completely.
   Do you really have a Xen kernel ? In which case youhave to pass the
   non-Xen kernel you really want to use with -k
2/ major: you don't have enough space on the boot media mindi tries to create
   Try increasing EXTRA_SPACE in /etc/mindi/mindi.conf to 200MB or more. 150MB
   seems to not be enough for your conf.

Bruno.
--
Open Source Profession, WW Linux Community Lead     http://www.hpintelco.net
HPE EMEA EG FLOSS Technology Strategist http://www.hpe.com/engage/opensource
FLOSS projects:    http://mondorescue.org         http://project-builder.org
Musique ancienne?   http://www.musique-ancienne.org  http://www.medieval.org

------------------------------------------------------------------------------
The Command Line: Reinvented for Modern Developers
Did the resurgence of CLI tooling catch you by surprise?
Reconnect with the command line and become more productive.
Learn the new .NET and ASP.NET CLI. Get your free copy!
http://sdm.link/telerik
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Mondo-devel] genisoimage: Uh oh, I cant find the boot image 'isolinux.bin' !

mrjoeyman
Thanks!!  I did change the EXTRA_SPACE in /etc/mindi/mindi.conf to 220MB, but I hope you can make it a little more clear on the Xen Kernel. Did you mean that I should use -k in grub start up of a different kernel than the one that is reporting to be a Xen kernel? I am not sure that I have 2 kernels. I am using Ubuntu Mate:
Release 16.04.1 LTS (Xenial Xerus) 64-bit
Kernel Linux 4.4.0-45-generic x86_64
MATE 1.12.1

Thank you.

Joel

On Mon, Oct 31, 2016 at 8:08 AM, Bruno Cornec-4 [via MondoRescue Mailing List] <[hidden email]> wrote:
Hello,

Joel West said on Sun, Oct 30, 2016 at 11:24:15PM -0400:

>Here are the files zipped like you asked. If I need to send them from some
>other email address, like one from the Mondo site or something please let
>me know. Thanks!

The e-mail address is now fine ! Thanks for the logs.

You seem to have 2 issues:
1/ minor: your main kernel is detected as a Xen kernel but not completely.
   Do you really have a Xen kernel ? In which case youhave to pass the
   non-Xen kernel you really want to use with -k
2/ major: you don't have enough space on the boot media mindi tries to create
   Try increasing EXTRA_SPACE in /etc/mindi/mindi.conf to 200MB or more. 150MB
   seems to not be enough for your conf.

Bruno.
--
Open Source Profession, WW Linux Community Lead     http://www.hpintelco.net
HPE EMEA EG FLOSS Technology Strategist http://www.hpe.com/engage/opensource
FLOSS projects:    http://mondorescue.org         http://project-builder.org
Musique ancienne?   http://www.musique-ancienne.org  http://www.medieval.org

------------------------------------------------------------------------------
The Command Line: Reinvented for Modern Developers
Did the resurgence of CLI tooling catch you by surprise?
Reconnect with the command line and become more productive.
Learn the new .NET and ASP.NET CLI. Get your free copy!
http://sdm.link/telerik
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel



To unsubscribe from genisoimage: Uh oh, I cant find the boot image 'isolinux.bin' !, click here.
NAML



--
"Before you criticize someone, walk a mile in their shoes. That way, you are a mile away, and you will have their shoes."
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Mondo-devel] genisoimage: Uh oh, I cant find the boot image 'isolinux.bin' !

Bruno Cornec-4
mrjoeyman said on Wed, Nov 02, 2016 at 04:28:38PM -0700:
>Did you
>mean that I should use -k in grub start up of a different kernel than the
>one that is reporting to be a Xen kernel? I am not sure that I have 2

Yes, use -k for the mondoarchive command to select a non Xen kernel.

>kernels. I am using Ubuntu Mate:
>Release 16.04.1 LTS (Xenial Xerus) 64-bit
>Kernel Linux 4.4.0-45-generic x86_64
>MATE 1.12.1

I wonder whether there isn't a name issue in the detection routine. I mean if you grep for xen and find xenial, maybe that's a problem !!
I'll have a look again knowing that.

Bruno.
--
Open Source Profession, WW Linux Community Lead     http://www.hpintelco.net
HPE EMEA EG FLOSS Technology Strategist http://www.hpe.com/engage/opensource
FLOSS projects:    http://mondorescue.org         http://project-builder.org
Musique ancienne?   http://www.musique-ancienne.org  http://www.medieval.org

------------------------------------------------------------------------------
Developer Access Program for Intel Xeon Phi Processors
Access to Intel Xeon Phi processor-based developer platforms.
With one year of Intel Parallel Studio XE.
Training and support from Colfax.
Order your platform today. http://sdm.link/xeonphi
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Loading...