Mondoarchive: Failed to create ISO#1

classic Classic list List threaded Threaded
19 messages Options
Reply | Threaded
Open this post in threaded view
|

Mondoarchive: Failed to create ISO#1

yann49
Hi,
Since I update my Debian/Jessie raid1 2 days ago I cannot make ISO mondo image of my system running MondoArchive v3.2.1-r3456 (and Mindi v3.0.1-r3456).
Before the damned update it had been working fine in making ISO image on DVDs (I made an image just before running the updates ... lucky).

Thinking it could be a hardware problem I installed an external IOMEGA DVD I have.
The result is the same : No ISO possible.

Next I ask for an ISO in a "/var/images" directory I created. I run my request to mondoarchive as follows (without sudo as I read here):
[quote] /home/roque# mondoarchive -Oi -d /var/images -S '/var/images' -E '/var/images|/home' -s 4480m [/quote]
Result is the same : Failed to create ISO#1.

Each time it seems that mondo failed in calling mkisofs for ISO creation. See below the end of the dialog console :
[quote] ....
---progress-form---1--- I am backing up your live filesystem now.
---progress-form---2--- ISO 1: [********************] 99% used
---progress-form---3--- Please wait. This may take a couple of hours.
---progress-form---E---
---progress-form---4--- TASK:  [***************.....]  75% done;  2:04 to go
Please be patient. Do not be alarmed by on-screen inactivity.
Call to mkisofs to make ISO (ISO #1) ...failed
---promptdialogYN---1--- Failed to create ISO #1. Retry?
---promptdialogYN---Q--- [yes] [no] --- [/quote]

Going to the web I read that mkisofs is been replaced with genisoimage in new version of distribution (is it true ?).
So to try to make it working I made a link to genisoimage renamed as mkisofs :

[quote] ln -s /usr/bin/genisoimage /usr/bin/mkisofs [/quote]

Unfortunately it did not work.

Having search all the day on the net, in mondorescue FAQ, etc. so I am back to square 1 and requesting support.

Thank you for your help (please keep in mind that I am new to Linux)


PS: I attached my mondoarchive log file.
Reply | Threaded
Open this post in threaded view
|

Re: [Mondo-devel] Mondoarchive: Failed to create ISO#1

Rob Borland
On 13/02/2016 8:03 PM, yann49 wrote:

> Hi,
> Since I update my Debian/Jessie raid1 2 days ago I cannot make ISO mondo
> image of my system running MondoArchive v3.2.1-r3456 (and Mindi
> v3.0.1-r3456).
> Before the damned update it had been working fine in making ISO image on
> DVDs (I made an image just before running the updates ... lucky).
>
> Thinking it could be a hardware problem I installed an external IOMEGA DVD I
> have.
> The result is the same : No ISO possible.
>
> Next I ask for an ISO in a "/var/images" directory I created. I run my
> request to mondoarchive as follows (without sudo as I read here):
> [quote] /home/roque# mondoarchive -Oi -d /var/images -S '/var/images' -E
> '/var/images|/home' -s 4480m [/quote]
> Result is the same : Failed to create ISO#1.
>
> Each time it seems that mondo failed in calling mkisofs for ISO creation.
> See below the end of the dialog console :
> [quote] ....
> ---progress-form---1--- I am backing up your live filesystem now.
> ---progress-form---2--- ISO 1: [********************] 99% used
> ---progress-form---3--- Please wait. This may take a couple of hours.
> ---progress-form---E---
> ---progress-form---4--- TASK:  [***************.....]  75% done;  2:04 to go
> Please be patient. Do not be alarmed by on-screen inactivity.
> Call to mkisofs to make ISO (ISO #1) ...failed
> ---promptdialogYN---1--- Failed to create ISO #1. Retry?
> ---promptdialogYN---Q--- [yes] [no] --- [/quote]
>
> Going to the web I read that mkisofs is been replaced with genisoimage in
> new version of distribution (is it true ?).
> So to try to make it working I made a link to genisoimage renamed as mkisofs
> :
>
> [quote] ln -s /usr/bin/genisoimage /usr/bin/mkisofs [/quote]
>
> Unfortunately it did not work.
It's not clear to me what it was that didn't work? Making the sym link?
Did you rename mkisofs (to something like mkisofs.old) before making the
link to genisofs?

In any case I think you will find that genisoimage will also fail and it
should be replaced by xorriso. After installing xorriso (using a Debian
package) rename genisoimage and link it to xorriso. You will end up with
a chain of sym links like this:

   mkisofs -> genisoimage -> xorriso

There has been some recent discussion of this issue here.

Regards,
Rob


------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|

Re: [Mondo-devel] Mondoarchive: Failed to create ISO#1

yann49
Hi Rob,

Thank you for considering my request and taking time for helping.

- What did not work is the creation of an ISO image (in a folder or on a DVD).

- The sym link in itself worked as the pseeudo mkisofs is in the /usr/bon directory.

- No I did not rename the mkisofs because it does not exist anymore since the last update !

- I understand that after installing xorriso (using Synaptic) I should run :
 "ln -s /usr/bin/xorriso /usr/bin/genisoimage"

Is that correct ?
Reply | Threaded
Open this post in threaded view
|

Re: [Mondo-devel] Mondoarchive: Failed to create ISO#1

Rob Borland
On 13/02/2016 11:43 PM, yann49 wrote:
> Hi Rob,
>
> Thank you for considering my request and taking time for helping.
>
> - What did not work is the creation of an ISO image (in a folder or on a
> DVD).
Thanks for the clarification.
> - The sym link in itself worked as the pseeudo mkisofs is in the /usr/bon
> directory.
>
> - No I did not rename the mkisofs because it does not exist anymore since
> the last update !
What do you get if you use the command "ls -l /usr/bin/mkisofs"?
>
> - I understand that after installing xorriso (using Synaptic) I should run :
>   "ln -s /usr/bin/xorriso /usr/bin/genisoimage"
>
> Is that correct ?
Please confirm that "ls -l /usr/bin/genisoimage" shows
"/usr/bin/isoimage -> /usr/bin/xorriso".

Did you try running mondoarchive after installing xorriso? If so, did
you see any difference?

Regards,
Rob

------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|

Re: [Mondo-devel] Mondoarchive: Failed to create ISO#1

yann49
Hi Rob,

Q:What do you get if you use the command "ls -l /usr/bin/mkisofs"?
A:lrwxrwxrwx 1 root root 20 févr. 13 16:30 /usr/bin/mkisofs -> /usr/bin/genisoimage

Q: Please confirm that "ls -l /usr/bin/genisoimage" shows "/usr/bin/isoimage -> /usr/bin/xorriso".
A: No, it shows "-rwxr-xr-x 1 root root 589424 juil. 22  2014 /usr/bin/genisoimage"
because I could not link genisoimage and xorriso as I got the following message :
"XYZ@bureau:~$ ln -s /usr/bin/xorriso /usr/bin/genisoimage
ln: impossible de créer le lien symbolique « /usr/bin/genisoimage »: Le fichier existe"
translate to "impossible to create symbolic link ...: the file already exists".

Q:Did you try running mondoarchive after installing xorriso? If so, did you see any difference?
A: Yes I run it but nothing diffrent as I got the same result :
"Call to mkisofs to make ISO (ISO #1) ...failed
---promptdialogYN---1--- Failed to create ISO #1. Retry?"

Have a good day
Reply | Threaded
Open this post in threaded view
|

Re: [Mondo-devel] Mondoarchive: Failed to create ISO#1

Rob Borland
On 14/02/2016 11:27 AM, yann49 wrote:
> Hi Rob,
>
> /Q:What do you get if you use the command "ls -l /usr/bin/mkisofs"?/
> A:lrwxrwxrwx 1 root root 20 févr. 13 16:30 /usr/bin/mkisofs ->
> /usr/bin/genisoimage

Good, this is what we want to see.

>
> /Q: Please confirm that "ls -l /usr/bin/genisoimage" shows
> "/usr/bin/isoimage -> /usr/bin/xorriso"./
> A: No, it shows "-rwxr-xr-x 1 root root 589424 juil. 22  2014
> /usr/bin/genisoimage"
> because I could not link genisoimage and xorriso as I got the following
> message :
> "XYZ@bureau:~$ ln -s /usr/bin/xorriso /usr/bin/genisoimage
> ln: impossible de créer le lien symbolique « /usr/bin/genisoimage »: Le
> fichier existe"
> translate to "impossible to create symbolic link ...: the file already
> exists".

You can't link an existing file to another file, the link file is a
specially formatted new file. So what you need to do is move genisoimage
out of the way and then create the link to xorriso, something like this:

mv /usr/bin/genisoimage /usr/bin/genisoimage.old
ln -s /usr/bin/xorriso /usr/bin/genisoimage

> /Q:Did you try running mondoarchive after installing xorriso? If so, did you
> see any difference?/
> A: Yes I run it but nothing diffrent as I got the same result :
> "Call to mkisofs to make ISO (ISO #1) ...failed
> ---promptdialogYN---1--- Failed to create ISO #1. Retry?"

So the call to mkisofs would be redirected to genisoimage, which fails.
After the steps above the call to genisoimage will be redirected to
xorriso which will (hopefully) work fine.

I think you are close to success. Thanks for your patience over this.

Bon chance,
Rob


------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|

Re: [Mondo-devel] Mondoarchive: Failed to create ISO#1

yann49
Hi Rob,

This is what I get now :
"Backup and/or verify ran to completion. Everything appears to be fine.
/var/cache/mindi/mondorescue.iso, a boot/utility CD, is available if you want it
Data archived OK.
Mondoarchive ran OK."

Thank you for your patience and support, in addition I learned a lot.
Have a good day

PS: Should I close the item somewhere
Reply | Threaded
Open this post in threaded view
|

Re: [Mondo-devel] Mondoarchive: Failed to create ISO#1

Rob Borland
On 14/02/2016 1:19 PM, yann49 wrote:
> Hi Rob,
>
> This is what I get now :
> "Backup and/or verify ran to completion. Everything appears to be fine.
> /var/cache/mindi/mondorescue.iso, a boot/utility CD, is available if you
> want it
> Data archived OK.
> Mondoarchive ran OK."

Very glad to hear that it's working now. Well done!

> Thank you for your patience and support, in addition I learned a lot.

That's what we're all here for!

PS: Should I close the item somewhere


You don't need to take any further action on the mailing list.

Regards,
Rob

------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|

[Mondo-devel] Debian 8 on UEFI Bios

Webmaster
Unfortunately Mondoarchive fails to create an ISO at all since the last
changes were made to use xorriso. It fails with
xorriso : FAILURE: Cannot find in ISO image: -boot_image ...
bin_path='/syslinux/isolinux.bin'

I checked the parameters given and it was given as 'syslinux/isolinux.bin'.

So I renamed xorrios to xorriso.old and wrote a wrapper script which
replaces above path to the absolute temp mondo path where the
isolinux.bin file is but then I get a different error:
xorriso: FAILURE : Cannot determine attributes of source file
'/tmp/mondo/scratch/mondo.scratch.nvA8SYS/syslinux/boot.cat' :  No such
file or directory

Any hints?

MfG Stefan Fröhlich
42 ;-)

------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|

Re: [Mondo-devel] Debian 8 on UEFI Bios

Marco Gaiarin
Mandi! Webmaster
  In chel di` si favelave...

> I checked the parameters given and it was given as 'syslinux/isolinux.bin'.

I confirm, latest beta does not suffer anymore of the '-efi-'/'--efi-'
parameters but now give an error on syslinux/isolinux.bin:

 DBG1: [Main] libmondo-archive.c->make_iso_fs#1704: Running mkisofs to make ISO #1
 DBG4: [Main] libmondo-files.c->find_home_of_exe#360: find_home_of_exe --- Found xorriso at /usr/bin/xorriso
 DBG1: [Main] libmondo-archive.c->make_iso_fs#1720: Making bootable backup
 DBG1: [Main] libmondo-archive.c->make_iso_fs#1727: make_cd_use_lilo is actually 0
 DBG1: [Main] libmondo-archive.c->make_iso_fs#1743: make_cd_use_lilo = FALSE
 DBG1: [Main] libmondo-archive.c->make_iso_fs#1744: Isolinux
 DBG3: [Main] libmondo-fork.c->eval_call_to_make_ISO#110: Starting
 DBG4: [Main] libmondo-fork.c->eval_call_to_make_ISO#132: basic call = 'xorriso -as mkisofs -r -p MondoRescue -publisher www.mondorescue.org -A Mondo_Rescue_GPL_Version -J -boot-info-table -no-emul-boot -b syslinux/isolinux.bin -c syslinux/boot.cat -boot-load-size 4  -eltorito-alt-boot --efi-boot images/mindi-bootroot.img -no-emul-boot -o '_ISO_' -V _CD#_ .'
 DBG4: [Main] libmondo-fork.c->eval_call_to_make_ISO#136: midway_call = 'xorriso -as mkisofs -r -p MondoRescue -publisher www.mondorescue.org -A Mondo_Rescue_GPL_Version -J -boot-info-table -no-emul-boot -b syslinux/isolinux.bin -c syslinux/boot.cat -boot-load-size 4  -eltorito-alt-boot --efi-boot images/mindi-bootroot.img -no-emul-boot -o '/srv/media/Ced/mondo/brucaliffo-20160215-1.iso' -V _CD#_ .'
 DBG4: [Main] libmondo-fork.c->eval_call_to_make_ISO#140: ultimate call = 'xorriso -as mkisofs -r -p MondoRescue -publisher www.mondorescue.org -A Mondo_Rescue_GPL_Version -J -boot-info-table -no-emul-boot -b syslinux/isolinux.bin -c syslinux/boot.cat -boot-load-size 4  -eltorito-alt-boot --efi-boot images/mindi-bootroot.img -no-emul-boot -o '/srv/media/Ced/mondo/brucaliffo-20160215-1.iso' -V 1 .'
 INFO: Please be patient. Do not be alarmed by on-screen inactivity.
 DBG4: [Main] libmondo-fork.c->eval_call_to_make_ISO#144: Calling open_evalcall_form() with what_i_am_doing='Running mkisofs to make ISO #1'
 DBG3: [Main] libmondo-fork.c->eval_call_to_make_ISO#173: command = 'xorriso -as mkisofs -r -p MondoRescue -publisher www.mondorescue.org -A Mondo_Rescue_GPL_Version -J -boot-info-table -no-emul-boot -b syslinux/isolinux.bin -c syslinux/boot.cat -boot-load-size 4  -eltorito-alt-boot --efi-boot images/mindi-bootroot.img -no-emul-boot -o '/srv/media/Ced/mondo/brucaliffo-20160215-1.iso' -V 1 . >> /var/log/mondoarchive.log'
 DBG3: [Main] libmondo-fork.c->run_external_binary_with_percentage_indicator_NEW#644: command = 'xorriso -as mkisofs -r -p MondoRescue -publisher www.mondorescue.org -A Mondo_Rescue_GPL_Version -J -boot-info-table -no-emul-boot -b syslinux/isolinux.bin -c syslinux/boot.cat -boot-load-size 4  -eltorito-alt-boot --efi-boot images/mindi-bootroot.img -no-emul-boot -o '/srv/media/Ced/mondo/brucaliffo-20160215-1.iso' -V 1 . >> /var/log/mondoarchive.log 2>> /var/log/mondoarchive.log'
 INFO: Running mkisofs to make ISO #1
 INFO:    Running mkisofs to make ISO #1  
 DBG4: [Main] libmondo-fork.c->run_prog_in_bkgd_then_exit#609: sz_command = 'xorriso -as mkisofs -r -p MondoRescue -publisher www.mondorescue.org -A Mondo_Rescue_GPL_Version -J -boot-info-table -no-emul-boot -b syslinux/isolinux.bin -c syslinux/boot.cat -boot-load-size 4  -eltorito-alt-boot --efi-boot images/mindi-bootroot.img -no-emul-boot -o '/srv/media/Ced/mondo/brucaliffo-20160215-1.iso' -V 1 . >> /var/log/mondoarchive.log 2>> /var/log/mondoarchive.log'
 xorriso 1.3.2 : RockRidge filesystem manipulator, libburnia project.

 Drive current: -outdev 'stdio:/srv/media/Ced/mondo/brucaliffo-20160215-1.iso'
 Media current: stdio file, overwriteable
 Media status : is blank
 Media summary: 0 sessions, 0 data blocks, 0 data,  355g free
 Added to ISO image: directory '/'='/var/tmp/mondo/scratch/mondo.scratch.7yekZ1'
 xorriso : UPDATE : 646 files added in 1 seconds
 xorriso : FAILURE : Cannot find in ISO image: -boot_image ... bin_path='/syslinux/isolinux.bin'
 xorriso : UPDATE : 646 files added in 1 seconds
 xorriso : aborting : -abort_on 'FAILURE' encountered 'FAILURE'
 DBG4: [Main] libmondo-fork.c->run_prog_in_bkgd_then_exit#614: child res = 5
 DBG3: [Main] libmondo-fork.c->run_external_binary_with_percentage_indicator_NEW#679: Parent res = 5
 INFO: Call to mkisofs to make ISO (ISO #1) ...failed
 DBG1: [Main] libmondo-archive.c->make_iso_fs#1822: WARNING - make_iso_fs returned an error
 DBG3: [Main] ../common/newt-specific.c->ask_me_yes_or_no#132: Exiting at first interaction request due to -F

In debian 'isolinux.bin' seems placed as:

        /usr/lib/ISOLINUX/isolinux.bin

--
dott. Marco Gaiarin        GNUPG Key ID: 240A3D66
  Associazione ``La Nostra Famiglia''                    http://www.sv.lnf.it/
  Polo FVG   -   Via della Bontà, 7 - 33078   -   San Vito al Tagliamento (PN)
  marco.gaiarin(at)lanostrafamiglia.it   t +39-0434-842711   f +39-0434-842797

                Dona il 5 PER MILLE a LA NOSTRA FAMIGLIA!
    http://www.lanostrafamiglia.it/25/index.php/component/k2/item/123
        (cf 00307430132, categoria ONLUS oppure RICERCA SANITARIA)

------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|

Re: [Mondo-devel] Debian 8 on UEFI Bios

Bruno Cornec-4
Marco Gaiarin said on Mon, Feb 15, 2016 at 04:02:23PM +0100:
>> I checked the parameters given and it was given as 'syslinux/isolinux.bin'.

which is what should be expected as normally at that point the current
working dir is at a place where you have syslinux as a subdir and these
files in it.

At least that's how it is working for genisoimage and mkisofs.

Now maybe that doesn't work for xorriso, and relative paths are not
supported or changed to full path names:

>I confirm, latest beta does not suffer anymore of the '-efi-'/'--efi-'
>parameters but now give an error on syslinux/isolinux.bin:

Good, at least some progress !

> DBG4: [Main] libmondo-fork.c->run_prog_in_bkgd_then_exit#609: sz_command = 'xorriso -as mkisofs -r -p MondoRescue -publisher www.mondorescue.org -A Mondo_Rescue_GPL_Version -J -boot-info-table -no-emul-boot -b syslinux/isolinux.bin -c syslinux/boot.cat -boot-load-size 4  -eltorito-alt-boot --efi-boot images/mindi-bootroot.img -no-emul-boot -o '/srv/media/Ced/mondo/brucaliffo-20160215-1.iso' -V 1 . >> /var/log/mondoarchive.log 2>> /var/log/mondoarchive.log'
[...]
> Added to ISO image: directory '/'='/var/tmp/mondo/scratch/mondo.scratch.7yekZ1'

Seems that it should then work relocating / here.

> xorriso : FAILURE : Cannot find in ISO image: -boot_image ... bin_path='/syslinux/isolinux.bin'

Or, there is a remaining issue making these files not available in that
context. Let me check again and come back to you.

>In debian 'isolinux.bin' seems placed as:
> /usr/lib/ISOLINUX/isolinux.bin

Yes but mindi should copy it in the right place. check the mindi log
part to verify that it's indeed found.

Bruno.
--
Open Source Profession, Linux Community Lead WW  http://www.hpintelco.net
HPE EMEA EG Open Source Technology Strategist http://hp.com/go/opensource
FLOSS projects:     http://mondorescue.org     http://project-builder.org
Musique ancienne? http://www.musique-ancienne.org http://www.medieval.org

------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|

Re: [Mondo-devel] Debian 8 on UEFI Bios

Bruno Cornec-4
Bruno Cornec said on Tue, Feb 16, 2016 at 12:55:10AM +0100:
>> xorriso : FAILURE : Cannot find in ISO image: -boot_image ... bin_path='/syslinux/isolinux.bin'
>
>Or, there is a remaining issue making these files not available in that
>context. Let me check again and come back to you.

Yes there is one. For UEFI systems, the directory under which these
files are placed is EFI not syslinux.

I'm making new packages for you to test (debian 7 & 8 amd64). Hopefully
that will cover all cases.

Bruno.
--
Open Source Profession, Linux Community Lead WW  http://www.hpintelco.net
HPE EMEA EG Open Source Technology Strategist http://hp.com/go/opensource
FLOSS projects:     http://mondorescue.org     http://project-builder.org
Musique ancienne? http://www.musique-ancienne.org http://www.medieval.org

------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|

Re: [Mondo-devel] Debian 8 on UEFI Bios

Webmaster


On 16/02/2016 10:19, Bruno Cornec wrote:

> Bruno Cornec said on Tue, Feb 16, 2016 at 12:55:10AM +0100:
>>> xorriso : FAILURE : Cannot find in ISO image: -boot_image ... bin_path='/syslinux/isolinux.bin'
>> Or, there is a remaining issue making these files not available in that
>> context. Let me check again and come back to you.
> Yes there is one. For UEFI systems, the directory under which these
> files are placed is EFI not syslinux.
>
> I'm making new packages for you to test (debian 7 & 8 amd64). Hopefully
> that will cover all cases.
>
> Bruno.
I tried the latest version. Now it fails at this point:
DBG4: [Main] libmondo-fork.c->run_prog_in_bkgd_then_exit#609: sz_command
= 'xorriso -as mkisofs -r -p MondoRescue -publisher www.mondorescue.org
-A Mondo_Rescue_GPL_Version -J -boot-info-table -no-emul-boot - -b
EFI/isolinux.bin -c EFI/boot.cat -boot-load-size 4 -eltorito-alt-boot
-efi-boot images/mindi-bootroot.img -no-emul-boot -o
'/mnt/mondo/FFA-SRV-01/backup/ISO/FFA-SRV-01-20160216-1334-1.iso' -V 1 .
 >> /var/log/mondoarchive.log 2>> /var/log/mondoarchive.log'
Calling xorriso -as mkisofs -r -p MondoRescue -publisher
www.mondorescue.org -A Mondo_Rescue_GPL_Version -J -boot-info-table
-no-emul-boot - -b EFI/isolinux.bin -c EFI/boot.cat -boot-load-size 4
-eltorito-alt-boot -efi-boot images/mindi-bootroot.img -no-emul-boot -o
/mnt/mondo/FFA-SRV-01/backup/ISO/FFA-SRV-01-20160216-1334-1.iso -V 1 .
xorriso 1.3.2 : RockRidge filesystem manipulator, libburnia project.

Drive current: -outdev
'stdio:/mnt/mondo/FFA-SRV-01/backup/ISO/FFA-SRV-01-20160216-1334-1.iso'
Media current: stdio file, overwriteable
Media status : is blank
Media summary: 0 sessions, 0 data blocks, 0 data,  248g free
xorriso : FAILURE : Cannot determine attributes of source file
'/tmp/mondo/scratch/mondo.scratch.QOCvHi/-' : No such file or directory
xorriso : aborting : -abort_on 'FAILURE' encountered 'FAILURE'

(Note: The output Calling xorriso ... is my wrapper)

MfG Stefan Froehlich
42 ;-)

------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|

Re: [Mondo-devel] Debian 8 on UEFI Bios

Bruno Cornec-4
Webmaster said on Tue, Feb 16, 2016 at 02:02:10PM +1000:
>'/tmp/mondo/scratch/mondo.scratch.QOCvHi/-' : No such file or directory

Argh !! My fixe didn't work as expected. Rework in progress.

Bruno.
--
Open Source Profession, Linux Community Lead WW  http://www.hpintelco.net
HPE EMEA EG Open Source Technology Strategist http://hp.com/go/opensource
FLOSS projects:     http://mondorescue.org     http://project-builder.org
Musique ancienne? http://www.musique-ancienne.org http://www.medieval.org

------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|

Re: [Mondo-devel] Debian 8 on UEFI Bios

Bruno Cornec-4
Bruno Cornec said on Tue, Feb 16, 2016 at 09:39:19AM +0100:
>Webmaster said on Tue, Feb 16, 2016 at 02:02:10PM +1000:
>>'/tmp/mondo/scratch/mondo.scratch.QOCvHi/-' : No such file or directory
>
>Argh !! My fixe didn't work as expected. Rework in progress.

Ok, I found my mistake, again sorry for that. I'm building new debian
packages again for you to test again as well. Expect them in about 10'.

Thanks for your patience,
Bruno.
--
Open Source Profession, Linux Community Lead WW  http://www.hpintelco.net
HPE EMEA EG Open Source Technology Strategist http://hp.com/go/opensource
FLOSS projects:     http://mondorescue.org     http://project-builder.org
Musique ancienne? http://www.musique-ancienne.org http://www.medieval.org

------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|

Re: [Mondo-devel] Debian 8 on UEFI Bios

Marco Gaiarin
In reply to this post by Bruno Cornec-4
Mandi! Bruno Cornec
  In chel di` si favelave...


> >In debian 'isolinux.bin' seems placed as:
> > /usr/lib/ISOLINUX/isolinux.bin
> Yes but mindi should copy it in the right place. check the mindi log
> part to verify that it's indeed found.

 INFO: Found isolinux.bin at /usr/lib/ISOLINUX/isolinux.bin

Yes, found.

I'll wait the next beta to do some tests. Thanks.

--
dott. Marco Gaiarin        GNUPG Key ID: 240A3D66
  Associazione ``La Nostra Famiglia''                    http://www.sv.lnf.it/
  Polo FVG   -   Via della Bontà, 7 - 33078   -   San Vito al Tagliamento (PN)
  marco.gaiarin(at)lanostrafamiglia.it   t +39-0434-842711   f +39-0434-842797

                Dona il 5 PER MILLE a LA NOSTRA FAMIGLIA!
    http://www.lanostrafamiglia.it/25/index.php/component/k2/item/123
        (cf 00307430132, categoria ONLUS oppure RICERCA SANITARIA)

------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|

Re: [Mondo-devel] Debian 8 on UEFI Bios

Bruno Cornec-4
Marco Gaiarin said on Tue, Feb 16, 2016 at 10:06:34AM +0100:
>I'll wait the next beta to do some tests. Thanks.

He Marco, what are you doing, it's already there ;-))))

But do not get accustomed to me answering rapidly as I'll be traveling
again the next 2 weeks, in the US and thus may have less bandwidth to
handle your reports.

Bruno.
--
Open Source Profession, Linux Community Lead WW  http://www.hpintelco.net
HPE EMEA EG Open Source Technology Strategist http://hp.com/go/opensource
FLOSS projects:     http://mondorescue.org     http://project-builder.org
Musique ancienne? http://www.musique-ancienne.org http://www.medieval.org

------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|

Re: [Mondo-devel] Debian 8 on UEFI Bios

Marco Gaiarin
Mandi! Bruno Cornec
  In chel di` si favelave...

> He Marco, what are you doing, it's already there ;-))))

Ok, with new version (3.2.220160216095908-0) backup finished OK!
Thanks!

Boot test probably today. Restore test probably friday.


> But do not get accustomed to me answering rapidly as I'll be traveling
> again the next 2 weeks, in the US and thus may have less bandwidth to
> handle your reports.

No probs. I leave feedback on list.

--
dott. Marco Gaiarin        GNUPG Key ID: 240A3D66
  Associazione ``La Nostra Famiglia''                    http://www.sv.lnf.it/
  Polo FVG   -   Via della Bontà, 7 - 33078   -   San Vito al Tagliamento (PN)
  marco.gaiarin(at)lanostrafamiglia.it   t +39-0434-842711   f +39-0434-842797

                Dona il 5 PER MILLE a LA NOSTRA FAMIGLIA!
    http://www.lanostrafamiglia.it/25/index.php/component/k2/item/123
        (cf 00307430132, categoria ONLUS oppure RICERCA SANITARIA)

------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|

Re: [Mondo-devel] Debian 8 on UEFI Bios

Webmaster
In reply to this post by Bruno Cornec-4


On 16/02/2016 18:59, Bruno Cornec wrote:
> Bruno Cornec said on Tue, Feb 16, 2016 at 09:39:19AM +0100:
>> Webmaster said on Tue, Feb 16, 2016 at 02:02:10PM +1000:
>>> '/tmp/mondo/scratch/mondo.scratch.QOCvHi/-' : No such file or directory
>> Argh !! My fixe didn't work as expected. Rework in progress.
> Ok, I found my mistake, again sorry for that. I'm building new debian
> packages again for you to test again as well. Expect them in about 10'.
>
Ok, Bruno. Well done. At least the ISO creates without any problem.
Unfortunately it is still not booting.

MfG Stefan Fröhlich
42 ;-)

------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel