[Mondo-devel] Question on how to run mondorestore with ISO images on a mounted CIFS share

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Mondo-devel] Question on how to run mondorestore with ISO images on a mounted CIFS share

Bergquist, Brett

I am just testing Mondo Rescue before I use it for an actual system.   The system that I will be using on is  Debian 6.x.   I have read the documentation, googled, looked at the email archive, etc. and I am missing something obvious.

 

I have ISO backup images that are available on a CIFS share that I made with “mondoarchive” . 

 

I boot off a mindi.iso that was made with “mondoarchive” and that boots fine.   It reports version “3.0.2-r3578” in the “/var/log/monorestor.log”

 

The IP address is not configured but that is a different issue and I can work around that by going to the shell and configuring the IP address.  

 

Using the text GUI I have no idea what options to pick to be able to access my ISO backup images.   I have goon through the documentation but am lost there.  The quick start show some images for backing up but nothing for restoring.   So I don’t know which option to pick (Hard disk or Net mount) and neither seem to work with what I am trying.

 

my CIFS share is on “192.169.1.10” and is “ctshare”.   My backup ISO’s are located at “/ctshare/backups/engserver”.  My /etc/fstab has

 

//192.169.1.10/ctshare /ctshare cifs user,auto, 0, 0

 

And I can create the directory “/ctshare” and then issue a “mount /ctshare” and the share is mounted with no issues so I know that is not the problem.   I’ve tried various iterations of the “mondorestore” command line with no success either.

 

So if someone could just tell me the magic to be able to restore in a situation like this, either from the GUI or from the command line, it will be much appreciated.



Canoga Perkins
20600 Prairie Street
Chatsworth, CA 91311
(818) 718-6300

This e-mail and any attached document(s) is confidential and is intended only for the review of the party to whom it is addressed. If you have received this transmission in error, please notify the sender immediately and discard the original message and any attachment(s).

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel

mondorestore.log (145K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Mondo-devel] Question on how to run mondorestore with ISO images on a mounted CIFS share

Gattegno, Victor (GSD CSC / GCC)-2

Hi,

 

I never tried mondorescue with CIFS, but with NFS I use -N -n mondoarchive options, I think that you should too ; when is used -n mondoarchive option, mondorestore should be able to mount your CIFS share and be able to find your iso backup images.

 

For these options, please check man page mondoarchive man(8).

 

Rgds,

Victor

 

From: Bergquist, Brett [mailto:[hidden email]]
Sent: mercredi 29 mars 2017 21:54
To: [hidden email]
Subject: [Mondo-devel] Question on how to run mondorestore with ISO images on a mounted CIFS share

 

I am just testing Mondo Rescue before I use it for an actual system.   The system that I will be using on is  Debian 6.x.   I have read the documentation, googled, looked at the email archive, etc. and I am missing something obvious.

 

I have ISO backup images that are available on a CIFS share that I made with “mondoarchive” . 

 

I boot off a mindi.iso that was made with “mondoarchive” and that boots fine.   It reports version “3.0.2-r3578” in the “/var/log/monorestor.log”

 

The IP address is not configured but that is a different issue and I can work around that by going to the shell and configuring the IP address.  

 

Using the text GUI I have no idea what options to pick to be able to access my ISO backup images.   I have goon through the documentation but am lost there.  The quick start show some images for backing up but nothing for restoring.   So I don’t know which option to pick (Hard disk or Net mount) and neither seem to work with what I am trying.

 

my CIFS share is on “192.169.1.10” and is “ctshare”.   My backup ISO’s are located at “/ctshare/backups/engserver”.  My /etc/fstab has

 

//192.169.1.10/ctshare /ctshare cifs user,auto, 0, 0

 

And I can create the directory “/ctshare” and then issue a “mount /ctshare” and the share is mounted with no issues so I know that is not the problem.   I’ve tried various iterations of the “mondorestore” command line with no success either.

 

So if someone could just tell me the magic to be able to restore in a situation like this, either from the GUI or from the command line, it will be much appreciated.

 


Canoga Perkins
20600 Prairie Street
Chatsworth, CA 91311
(818) 718-6300

This e-mail and any attached document(s) is confidential and is intended only for the review of the party to whom it is addressed. If you have received this transmission in error, please notify the sender immediately and discard the original message and any attachment(s).


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Loading...