Quantcast

[Mondo-devel] Mindi fails

classic Classic list List threaded Threaded
19 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Mondo-devel] Mindi fails

Bo Karlsson
Hello,
My first troubles with Mondorescue. Trying to backup a new install of CentOS
7 when mindi stops with the following error:
---
Mindi failed to create your boot+data disks.
Fatal error... Failed to generate boot+data disks
---FATALERROR--- Failed to generate boot+data disks
If you require technical support, please contact the mailing list.
See http://www.mondorescue.org for details.
The list's members can help you, if you attach that file to your e-mail.
Log file: /var/log/mondoarchive.log
Mondo has aborted.
rm: cannot remove â/tmp/mondo.tmp.QHqqWX/mountpoint.15991â: Device or
resource busy
Execution run ended; result=254
Type 'less /var/log/mondoarchive.log' to see the output log
---

In the log it looks as Mindi runs out of space, tried again and checked the
space with "df" and it looks to be plenty:
 
Filesystem      Size  Used Avail Use% Mounted on
/dev/md0         20G  2.9G   16G  16% /
devtmpfs        7.8G     0  7.8G   0% /dev
tmpfs           7.8G     0  7.8G   0% /dev/shm
tmpfs           7.8G  8.6M  7.8G   1% /run
tmpfs           7.8G     0  7.8G   0% /sys/fs/cgroup
/dev/md2        832G  228M  790G   1% /web
/dev/md1         50G  737M   46G   2% /var
tmpfs           1.6G     0  1.6G   0% /run/user/0
/dev/loop0      169M  2.2M  165M   2%
/var/tmp/mondo.tmp.IAe7Lx/mountpoint.2657

It is a basic CentOS 7 installation with RAID1 without LVM on a Fujitsu
RX1330M1, mondoarchive v3.2.1-r3456 installed from repo.

Command: mondoarchive -Oid /var/backup -p `hostname -s` -E
"/backup|/var/backup|/var/log/apache/httpd_old" -s 4200m -9
 
Attached mondoarchive.log

Best Regards,
Bo Karlsson


------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel

mondoarchive.log.gz (31K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Mondo-devel] Mindi fails

Bruno Cornec-4
Bo Karlsson said on Tue, Feb 16, 2016 at 11:52:30AM +0100:
>My first troubles with Mondorescue. Trying to backup a new install of CentOS
>7 when mindi stops with the following error:
>---
>Mindi failed to create your boot+data disks.
>Fatal error... Failed to generate boot+data disks

In fact:
/usr/sbin/mindi: line 236: echo: write error: No space left on device

So try to increase EXTRA_SIZE and BOOT_SIZE in /etc/mindi/mindi.conf

Bruno.
--
Open Source Profession, Linux Community Lead WW  http://www.hpintelco.net
HPE EMEA EG Open Source Technology Strategist http://hp.com/go/opensource
FLOSS projects:     http://mondorescue.org     http://project-builder.org
Musique ancienne? http://www.musique-ancienne.org http://www.medieval.org

------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Mondo-devel] Mondoarchive with Debian 8 on UEFI BIOS

Webmaster
In reply to this post by Bo Karlsson
Ok, i can create backups again and it creates an ISO but this ISO is not
bootable, not on a UEFI Bios machine and not on a Legacy Bios machine.
I noticed that the first call to xorriso is without "-as mkisofs" and
that fails:
Invoking /usr/bin/xorriso -U -J -r -v -p Mindi -publisher
http://www.mondorescue.org -A Mindi -eltorito-alt-boot -efi-boot
images/mindi-bootroot.img -no-emul-boot -eltorito-alt-boot --efi-boot
images/mindi-bootroot.img -no-emul-boot -V Mindi_Image -o
/tmp/mondo/scratch/mondo.scratch.JTyD2G/images/mindi.iso -b
EFI/isolinux.bin -c EFI/boot.cat -no-emul-boot -boot-load-size 4
-boot-info-table
----------- /usr/bin/xorriso's errors --------------
/usr/bin/xorriso -U -J -r -v -p Mindi -publisher
http://www.mondorescue.org -A Mindi -eltorito-alt-boot
-eltorito-platform 0xEF -eltorito-boot images/mindi-bootroot.img
-no-emul-boot -eltorito-alt-boot -eltorito-platform 0xEF -eltorito-boot
images/mindi-bootroot.img -no-emul-boot -V Mindi_Image -o
/tmp/mondo/scratch/mondo.scratch.JTyD2G/images/mindi.iso -b
EFI/isolinux.bin -c EFI/boot.cat -no-emul-boot -boot-load-size 4
-boot-info-table returned the following errors:
xorriso 1.3.2 : RockRidge filesystem manipulator, libburnia project.
xorriso : FAILURE : Not a known command:  '-U'
xorriso : FAILURE : Not a known command:  '-J'
....
xorriso : aborting : -abort_on 'FAILURE' encountered 'FAILURE'
ERROR: Failed to create ISO image.

Despite of this error the ISO seems to be created and later in the
logfile it says:
INFO: Boot and data disk images were created.

MfG Stefan Fröhlich
42 ;-)

------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Mondo-devel] Mondoarchive with Debian 8 on UEFI BIOS

Bruno Cornec-4
Hello,

Webmaster said on Wed, Feb 17, 2016 at 11:25:00PM +1000:
>Ok, i can create backups again and it creates an ISO but this ISO is not
>bootable, not on a UEFI Bios machine and not on a Legacy Bios machine.

What happens when you try to boot ?
In UEFI are you able to see the UEFI partition on the media ?

>I noticed that the first call to xorriso is without "-as mkisofs" and

I just fixed that for mindi as well. That image is not used as such by
mondoarchive, that's why it worls to build it.

Bruno.
--
Open Source Profession, Linux Community Lead WW  http://www.hpintelco.net
HPE EMEA EG Open Source Technology Strategist http://hp.com/go/opensource
FLOSS projects:     http://mondorescue.org     http://project-builder.org
Musique ancienne? http://www.musique-ancienne.org http://www.medieval.org

------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Mondo-devel] Mondoarchive with Debian 8 on UEFI BIOS

Stefan Froehlich


On 18/02/2016 9:07, Bruno Cornec wrote:
> Hello,
>
> Webmaster said on Wed, Feb 17, 2016 at 11:25:00PM +1000:
>> Ok, i can create backups again and it creates an ISO but this ISO is not
>> bootable, not on a UEFI Bios machine and not on a Legacy Bios machine.
> What happens when you try to boot ?
> In UEFI are you able to see the UEFI partition on the media ?
I use VMWare Workstation 12 Player. When enabling EFI Bios it just shows
Attempting to start up from:
-> EFI VMware Virtual SCSI Hard Drive (0.0) ... unsuccessful.
-> EFI VMware Virtual CDROM Drive (IDE 1:0) ... unsuccessful.
-> EFI Network...

and after a while it goes into the EFI Bios.

You can easily reproduce it. Create a VMWare virtual machine, set it to
EFI Bios, install Debian, install Mondo and all resulting ISOs will
behave like this. If you create a Legacy BIOS virtual machine, set up
Debian there and create an ISO with Mondo it works just fine.

MfG Stefan Fröhlich
42 ;-)

------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Mondo-devel] Mindi fails

Bo Karlsson
In reply to this post by Bruno Cornec-4
Thanks,
Now it works. Ended up with:
EXTRA_SPACE=160304
BOOT_SIZE=98304

Best Regards,
Bo Karlsson

-----Ursprungligt meddelande-----
Från: Bruno Cornec [mailto:[hidden email]]
Skickat: den 17 februari 2016 13:47
Till: Mondo mailing list
Ämne: Re: [Mondo-devel] Mindi fails

Bo Karlsson said on Tue, Feb 16, 2016 at 11:52:30AM +0100:
>My first troubles with Mondorescue. Trying to backup a new install of
CentOS
>7 when mindi stops with the following error:
>---
>Mindi failed to create your boot+data disks.
>Fatal error... Failed to generate boot+data disks

In fact:
/usr/sbin/mindi: line 236: echo: write error: No space left on device

So try to increase EXTRA_SIZE and BOOT_SIZE in /etc/mindi/mindi.conf

Bruno.
--
Open Source Profession, Linux Community Lead WW  http://www.hpintelco.net
HPE EMEA EG Open Source Technology Strategist http://hp.com/go/opensource
FLOSS projects:     http://mondorescue.org     http://project-builder.org
Musique ancienne? http://www.musique-ancienne.org http://www.medieval.org

----------------------------------------------------------------------------
--
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel


------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Mondo-devel] Mondoarchive with Debian 8 on UEFI BIOS

Stefan Froehlich
In reply to this post by Stefan Froehlich


On 18/02/2016 13:46, Stefan Froehlich wrote:

> On 18/02/2016 9:07, Bruno Cornec wrote:
>> Hello,
>>
>> Webmaster said on Wed, Feb 17, 2016 at 11:25:00PM +1000:
>>> Ok, i can create backups again and it creates an ISO but this ISO is not
>>> bootable, not on a UEFI Bios machine and not on a Legacy Bios machine.
>> What happens when you try to boot ?
>> In UEFI are you able to see the UEFI partition on the media ?
> I use VMWare Workstation 12 Player. When enabling EFI Bios it just shows
> Attempting to start up from:
> -> EFI VMware Virtual SCSI Hard Drive (0.0) ... unsuccessful.
> -> EFI VMware Virtual CDROM Drive (IDE 1:0) ... unsuccessful.
> -> EFI Network...
>
> and after a while it goes into the EFI Bios.
>
> You can easily reproduce it. Create a VMWare virtual machine, set it to
> EFI Bios, install Debian, install Mondo and all resulting ISOs will
> behave like this. If you create a Legacy BIOS virtual machine, set up
> Debian there and create an ISO with Mondo it works just fine.
Some further info:
It looks like the ISO file was generated with an invalid boot image. I
extracted the boot image. I inserted a boot image from CloneZilla into
the ISO and now it boots at least. Of course it doesn't go very far. I
see the grub boot prompt there.

MfG Stefan Fröhlich
42 ;-)

------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Mondo-devel] Mondoarchive with Debian 8 on UEFI BIOS

Bruno Cornec-4
Stefan Froehlich said on Sun, Feb 21, 2016 at 10:45:01PM +1000:

>On 18/02/2016 13:46, Stefan Froehlich wrote:
>> On 18/02/2016 9:07, Bruno Cornec wrote:
>>> Hello,
>>>
>>> Webmaster said on Wed, Feb 17, 2016 at 11:25:00PM +1000:
>>>> Ok, i can create backups again and it creates an ISO but this ISO is not
>>>> bootable, not on a UEFI Bios machine and not on a Legacy Bios machine.
>>> What happens when you try to boot ?
>>> In UEFI are you able to see the UEFI partition on the media ?
>> I use VMWare Workstation 12 Player. When enabling EFI Bios it just shows
>> Attempting to start up from:
>> -> EFI VMware Virtual SCSI Hard Drive (0.0) ... unsuccessful.
>> -> EFI VMware Virtual CDROM Drive (IDE 1:0) ... unsuccessful.
>> -> EFI Network...
>>
>> and after a while it goes into the EFI Bios.
>>
>> You can easily reproduce it. Create a VMWare virtual machine, set it to
>> EFI Bios, install Debian, install Mondo and all resulting ISOs will
>> behave like this. If you create a Legacy BIOS virtual machine, set up
>> Debian there and create an ISO with Mondo it works just fine.
>Some further info:
>It looks like the ISO file was generated with an invalid boot image. I
>extracted the boot image. I inserted a boot image from CloneZilla into
>the ISO and now it boots at least. Of course it doesn't go very far. I
>see the grub boot prompt there.

This is normal for now as mindi doesn't support grub2 as a boot loader.
I'm working on it ATM as well for RHEL7.

Bruno.
--
Open Source Profession, Linux Community Lead WW  http://www.hpintelco.net
HPE EMEA EG Open Source Technology Strategist http://hp.com/go/opensource
FLOSS projects:     http://mondorescue.org     http://project-builder.org
Musique ancienne? http://www.musique-ancienne.org http://www.medieval.org

------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Mondo-devel] Mondoarchive with Debian 8 on UEFI BIOS

Stefan Froehlich


On 22/02/2016 4:34, Bruno Cornec wrote:

> Stefan Froehlich said on Sun, Feb 21, 2016 at 10:45:01PM +1000:
>> On 18/02/2016 13:46, Stefan Froehlich wrote:
>>> On 18/02/2016 9:07, Bruno Cornec wrote:
>>>> Hello,
>>>>
>>>> Webmaster said on Wed, Feb 17, 2016 at 11:25:00PM +1000:
>>>>> Ok, i can create backups again and it creates an ISO but this ISO is not
>>>>> bootable, not on a UEFI Bios machine and not on a Legacy Bios machine.
>>>> What happens when you try to boot ?
>>>> In UEFI are you able to see the UEFI partition on the media ?
>>> I use VMWare Workstation 12 Player. When enabling EFI Bios it just shows
>>> Attempting to start up from:
>>> -> EFI VMware Virtual SCSI Hard Drive (0.0) ... unsuccessful.
>>> -> EFI VMware Virtual CDROM Drive (IDE 1:0) ... unsuccessful.
>>> -> EFI Network...
>>>
>>> and after a while it goes into the EFI Bios.
>>>
>>> You can easily reproduce it. Create a VMWare virtual machine, set it to
>>> EFI Bios, install Debian, install Mondo and all resulting ISOs will
>>> behave like this. If you create a Legacy BIOS virtual machine, set up
>>> Debian there and create an ISO with Mondo it works just fine.
>> Some further info:
>> It looks like the ISO file was generated with an invalid boot image. I
>> extracted the boot image. I inserted a boot image from CloneZilla into
>> the ISO and now it boots at least. Of course it doesn't go very far. I
>> see the grub boot prompt there.
> This is normal for now as mindi doesn't support grub2 as a boot loader.
> I'm working on it ATM as well for RHEL7.
But it is not normal that the image doesn't contain a valid boot image,
is it?

MfG Stefan Fröhlich
42 ;-)

------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Mondo-devel] Mondoarchive with Debian 8 on UEFI BIOS

Bruno Cornec-4
Stefan Froehlich said on Tue, Feb 23, 2016 at 09:23:47PM +1000:
>>> It looks like the ISO file was generated with an invalid boot image. I
>>> extracted the boot image. I inserted a boot image from CloneZilla into
>>> the ISO and now it boots at least. Of course it doesn't go very far. I
>>> see the grub boot prompt there.
>> This is normal for now as mindi doesn't support grub2 as a boot loader.
>> I'm working on it ATM as well for RHEL7.
>But it is not normal that the image doesn't contain a valid boot image,
>is it?

Well it is not normal as eerybody expect it to work, but currently the
code doesn't support UEFI with grub2 as a boot loader.

The standard way of working of MondoRescue in BIOS boot mode is to build
bootable media with the syslinux tools suite (syslinux for USB, isolinux
for CD, pxelinux for Net).

However, syslinux doesn't work in UEFI mode as far as I can tell (made
tries, reported to the syslinux ML without solution up to now).

So for UEFI boot mode we need to add support for other boot loaders.
I've done grub for distros such as RHEL 6, but not grub3 for distros
such as Debian 8 or RHEL 7.

Well I have started last week to make the appropriate patches for that,
but haven't finished yet. As long as that work isn't done, you won't get
a correct bootable image made by mindi. So it is normal that your image
doesn't boot.

Bruno.
--
Open Source Profession, Linux Community Lead WW  http://www.hpintelco.net
HPE EMEA EG Open Source Technology Strategist http://hp.com/go/opensource
FLOSS projects:     http://mondorescue.org     http://project-builder.org
Musique ancienne? http://www.musique-ancienne.org http://www.medieval.org

------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Mondo-devel] Mondoarchive with Debian 8 on UEFI BIOS

Marco Gaiarin
Mandi! Bruno Cornec
  In chel di` si favelave...

> Well I have started last week to make the appropriate patches for that,
> but haven't finished yet. As long as that work isn't done, you won't get
> a correct bootable image made by mindi. So it is normal that your image
> doesn't boot.

Ok, good to know.

I've burned some DVD, indeed, because the boot process fail in some
strange way: beeps, ... that remember me the time when we boot linux
from floppies... ;-)))


Waiting for the next release... ;-)))

--
dott. Marco Gaiarin        GNUPG Key ID: 240A3D66
  Associazione ``La Nostra Famiglia''                    http://www.sv.lnf.it/
  Polo FVG   -   Via della Bontà, 7 - 33078   -   San Vito al Tagliamento (PN)
  marco.gaiarin(at)lanostrafamiglia.it   t +39-0434-842711   f +39-0434-842797

                Dona il 5 PER MILLE a LA NOSTRA FAMIGLIA!
    http://www.lanostrafamiglia.it/25/index.php/component/k2/item/123
        (cf 00307430132, categoria ONLUS oppure RICERCA SANITARIA)

------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Mondo-devel] Mondoarchive with Debian 8 on UEFI BIOS

Stefan Froehlich
In reply to this post by Bruno Cornec-4


On 25/02/2016 16:12, Bruno Cornec wrote:

> Stefan Froehlich said on Tue, Feb 23, 2016 at 09:23:47PM +1000:
>>>> It looks like the ISO file was generated with an invalid boot image. I
>>>> extracted the boot image. I inserted a boot image from CloneZilla into
>>>> the ISO and now it boots at least. Of course it doesn't go very far. I
>>>> see the grub boot prompt there.
>>> This is normal for now as mindi doesn't support grub2 as a boot loader.
>>> I'm working on it ATM as well for RHEL7.
>> But it is not normal that the image doesn't contain a valid boot image,
>> is it?
> Well it is not normal as eerybody expect it to work, but currently the
> code doesn't support UEFI with grub2 as a boot loader.
>
> The standard way of working of MondoRescue in BIOS boot mode is to build
> bootable media with the syslinux tools suite (syslinux for USB, isolinux
> for CD, pxelinux for Net).
>
> However, syslinux doesn't work in UEFI mode as far as I can tell (made
> tries, reported to the syslinux ML without solution up to now).
>
> So for UEFI boot mode we need to add support for other boot loaders.
> I've done grub for distros such as RHEL 6, but not grub3 for distros
> such as Debian 8 or RHEL 7.
>
> Well I have started last week to make the appropriate patches for that,
> but haven't finished yet. As long as that work isn't done, you won't get
> a correct bootable image made by mindi. So it is normal that your image
> doesn't boot.
>
> Bruno.
Hi Bruno,

anything new to this one?

Stefan

------------------------------------------------------------------------------
Transform Data into Opportunity.
Accelerate data analysis in your applications with
Intel Data Analytics Acceleration Library.
Click to learn more.
http://pubads.g.doubleclick.net/gampad/clk?id=278785351&iu=/4140
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Mondo-devel] Mondoarchive with Debian 8 on UEFI BIOS

Bruno Cornec-4
Stefan Froehlich said on Wed, Mar 23, 2016 at 05:45:44PM +1000:

>On 25/02/2016 16:12, Bruno Cornec wrote:
>> Stefan Froehlich said on Tue, Feb 23, 2016 at 09:23:47PM +1000:
>>>>> It looks like the ISO file was generated with an invalid boot image. I
>>>>> extracted the boot image. I inserted a boot image from CloneZilla into
>>>>> the ISO and now it boots at least. Of course it doesn't go very far. I
>>>>> see the grub boot prompt there.
>>>> This is normal for now as mindi doesn't support grub2 as a boot loader.
>>>> I'm working on it ATM as well for RHEL7.
>>> But it is not normal that the image doesn't contain a valid boot image,
>>> is it?
>> Well it is not normal as eerybody expect it to work, but currently the
>> code doesn't support UEFI with grub2 as a boot loader.
>>
>> So for UEFI boot mode we need to add support for other boot loaders.
>> I've done grub for distros such as RHEL 6, but not grub2 for distros
>> such as Debian 8 or RHEL 7.
>>
>> Well I have started last week to make the appropriate patches for that,
>> but haven't finished yet. As long as that work isn't done, you won't get
>> a correct bootable image made by mindi. So it is normal that your image
>> doesn't boot.
>anything new to this one?

I've made patches this week in order to have mindi working fine (I do my
tests with RHEL7, but there is no reason Debian8 would not work for
that). I'm still working on adding he same "magic" in mondoarchive as
well so it could work globally.

Cf:
https://brunocornec.wordpress.com/2016/03/22/progresses-with-mondorescue-3-2-2/

Bruno.
--
Open Source Profession, WW Linux Community Lead  http://www.hpintelco.net
HPE EMEA EG Open Source Technology Strategist http://hp.com/go/opensource
FLOSS projects:     http://mondorescue.org     http://project-builder.org
Musique ancienne? http://www.musique-ancienne.org http://www.medieval.org

------------------------------------------------------------------------------
Transform Data into Opportunity.
Accelerate data analysis in your applications with
Intel Data Analytics Acceleration Library.
Click to learn more.
http://pubads.g.doubleclick.net/gampad/clk?id=278785351&iu=/4140
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Mondo-devel] Mondoarchive with Debian 8 on UEFI BIOS

Stefan Froehlich


On 24/03/2016 2:19, Bruno Cornec wrote:

> Stefan Froehlich said on Wed, Mar 23, 2016 at 05:45:44PM +1000:
>> On 25/02/2016 16:12, Bruno Cornec wrote:
>>> Stefan Froehlich said on Tue, Feb 23, 2016 at 09:23:47PM +1000:
>>>>>> It looks like the ISO file was generated with an invalid boot image. I
>>>>>> extracted the boot image. I inserted a boot image from CloneZilla into
>>>>>> the ISO and now it boots at least. Of course it doesn't go very far. I
>>>>>> see the grub boot prompt there.
>>>>> This is normal for now as mindi doesn't support grub2 as a boot loader.
>>>>> I'm working on it ATM as well for RHEL7.
>>>> But it is not normal that the image doesn't contain a valid boot image,
>>>> is it?
>>> Well it is not normal as eerybody expect it to work, but currently the
>>> code doesn't support UEFI with grub2 as a boot loader.
>>>
>>> So for UEFI boot mode we need to add support for other boot loaders.
>>> I've done grub for distros such as RHEL 6, but not grub2 for distros
>>> such as Debian 8 or RHEL 7.
>>>
>>> Well I have started last week to make the appropriate patches for that,
>>> but haven't finished yet. As long as that work isn't done, you won't get
>>> a correct bootable image made by mindi. So it is normal that your image
>>> doesn't boot.
>> anything new to this one?
> I've made patches this week in order to have mindi working fine (I do my
> tests with RHEL7, but there is no reason Debian8 would not work for
> that). I'm still working on adding he same "magic" in mondoarchive as
> well so it could work globally.
>
> Cf:
> https://brunocornec.wordpress.com/2016/03/22/progresses-with-mondorescue-3-2-2/
>
> Bruno.
Any news to this?
Still having that issue...

MfG Stefan Fröhlich
42 ;-)

------------------------------------------------------------------------------
What NetFlow Analyzer can do for you? Monitors network bandwidth and traffic
patterns at an interface-level. Reveals which users, apps, and protocols are
consuming the most bandwidth. Provides multi-vendor support for NetFlow,
J-Flow, sFlow and other flows. Make informed decisions using capacity
planning reports. https://ad.doubleclick.net/ddm/clk/305295220;132659582;e
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Mondo-devel] Mondoarchive with Debian 8 on UEFI BIOS

Bruno Cornec-4
Stefan Froehlich said on Tue, May 31, 2016 at 04:51:17PM +1000:

>>> anything new to this one?
>> I've made patches this week in order to have mindi working fine (I do my
>> tests with RHEL7, but there is no reason Debian8 would not work for
>> that). I'm still working on adding he same "magic" in mondoarchive as
>> well so it could work globally.
>>
>> Cf:
>> https://brunocornec.wordpress.com/2016/03/22/progresses-with-mondorescue-3-2-2/
>>
>> Bruno.
>Any news to this?
>Still having that issue...

Yes, there is something missing for Debian as it seems obvisouly. Will work on it
after the PoC I'm on for next week and the Event I'll attend in Sweden the week
after (so starting 20th of June). Of course, any patch earlier could help speed up
stuff.

Bruno.
--
Open Source Profession, WW Linux Community Lead  http://www.hpintelco.net
HPE EMEA EG Open Source Technology Strategist http://hp.com/go/opensource
FLOSS projects:     http://mondorescue.org     http://project-builder.org
Musique ancienne? http://www.musique-ancienne.org http://www.medieval.org

------------------------------------------------------------------------------
What NetFlow Analyzer can do for you? Monitors network bandwidth and traffic
patterns at an interface-level. Reveals which users, apps, and protocols are
consuming the most bandwidth. Provides multi-vendor support for NetFlow,
J-Flow, sFlow and other flows. Make informed decisions using capacity
planning reports. https://ad.doubleclick.net/ddm/clk/305295220;132659582;e
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Mondo-devel] Mondoarchive with Debian 8 on UEFI BIOS

Stefan Froehlich
In reply to this post by Marco Gaiarin
Hi Bruno,

any news on this one?

Cheers,

Stefan


On 25/02/2016 20:34, Marco Gaiarin wrote:

> Mandi! Bruno Cornec
>    In chel di` si favelave...
>
>> Well I have started last week to make the appropriate patches for that,
>> but haven't finished yet. As long as that work isn't done, you won't get
>> a correct bootable image made by mindi. So it is normal that your image
>> doesn't boot.
> Ok, good to know.
>
> I've burned some DVD, indeed, because the boot process fail in some
> strange way: beeps, ... that remember me the time when we boot linux
> from floppies... ;-)))
>
>
> Waiting for the next release... ;-)))
>

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Mondo-devel] Mondoarchive with Debian 8 on UEFI BIOS

Bruno Cornec-4
Hello Stefan,

No due to the preparation of LinuxCon and the fact I attend the event this
week, I've not been able to make progress. I know this is frustrating for
people waiting for it, but MondoRescue is not part of my day job.

However, next week seems more reasoable from an agenda perspective, so I'll
do my best to work on it. No big promise, but that will be the next topic
I'll work on for MondoRescue for sure, as it's been waiting till too long now.

THaks for your patience, and as usual, patches always welcome,
Bruno.

Stefan Froehlich said on Wed, Oct 05, 2016 at 10:44:45PM +1000:
>any news on this one?
--
Open Source Profession, WW Linux Community Lead     http://www.hpintelco.net
HPE EMEA EG FLOSS Technology Strategist http://www.hpe.com/engage/opensource
FLOSS projects:    http://mondorescue.org         http://project-builder.org
Musique ancienne?   http://www.musique-ancienne.org  http://www.medieval.org

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Mondo-devel] Mondoarchive with Debian 8 on UEFI BIOS

Stefan Froehlich
Hi Bruno,

sorry to ask you again. Is that still in your queue?

Stefan


On 6/10/2016 7:19, Bruno Cornec wrote:

> Hello Stefan,
>
> No due to the preparation of LinuxCon and the fact I attend the event this
> week, I've not been able to make progress. I know this is frustrating for
> people waiting for it, but MondoRescue is not part of my day job.
>
> However, next week seems more reasoable from an agenda perspective, so I'll
> do my best to work on it. No big promise, but that will be the next topic
> I'll work on for MondoRescue for sure, as it's been waiting till too long now.
>
> THaks for your patience, and as usual, patches always welcome,
> Bruno.
>
> Stefan Froehlich said on Wed, Oct 05, 2016 at 10:44:45PM +1000:
>> any news on this one?

------------------------------------------------------------------------------
Developer Access Program for Intel Xeon Phi Processors
Access to Intel Xeon Phi processor-based developer platforms.
With one year of Intel Parallel Studio XE.
Training and support from Colfax.
Order your platform today.http://sdm.link/xeonphi
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Mondo-devel] Mondoarchive with Debian 8 on UEFI BIOS

Bruno Cornec-4
Hello,

Yes this is still in the queue. I'm this week in the US and won't be able to work on it. Starting next week I have plan to dedicated some time time to fix some of the outstanding problems on MondoRescue including that one.

Hope I won't get any more urgent request meanwhile as this has waited for way too long I know :-(

Bruno.

Stefan Froehlich said on Thu, Dec 08, 2016 at 08:45:32PM +1000:

>Hi Bruno,
>
>sorry to ask you again. Is that still in your queue?
>
>Stefan
>
>
>On 6/10/2016 7:19, Bruno Cornec wrote:
>> Hello Stefan,
>>
>> No due to the preparation of LinuxCon and the fact I attend the event this
>> week, I've not been able to make progress. I know this is frustrating for
>> people waiting for it, but MondoRescue is not part of my day job.
>>
>> However, next week seems more reasoable from an agenda perspective, so I'll
>> do my best to work on it. No big promise, but that will be the next topic
>> I'll work on for MondoRescue for sure, as it's been waiting till too long now.
>>
>> THaks for your patience, and as usual, patches always welcome,
>> Bruno.
>>
>> Stefan Froehlich said on Wed, Oct 05, 2016 at 10:44:45PM +1000:
>>> any news on this one?
>
>------------------------------------------------------------------------------
>Developer Access Program for Intel Xeon Phi Processors
>Access to Intel Xeon Phi processor-based developer platforms.
>With one year of Intel Parallel Studio XE.
>Training and support from Colfax.
>Order your platform today.http://sdm.link/xeonphi
>_______________________________________________
>Mondo-devel mailing list
>[hidden email]
>https://lists.sourceforge.net/lists/listinfo/mondo-devel

--
Open Source Profession, WW Linux Community Lead     http://www.hpintelco.net
HPE EMEA EG FLOSS Technology Strategist http://www.hpe.com/engage/opensource
FLOSS projects:    http://mondorescue.org         http://project-builder.org
Musique ancienne?   http://www.musique-ancienne.org  http://www.medieval.org

------------------------------------------------------------------------------
Developer Access Program for Intel Xeon Phi Processors
Access to Intel Xeon Phi processor-based developer platforms.
With one year of Intel Parallel Studio XE.
Training and support from Colfax.
Order your platform today.http://sdm.link/xeonphi
_______________________________________________
Mondo-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mondo-devel
Loading...